Overriding Composer Stability Requirement

There are situations in which you're working with a legacy system that is dependent on a particular (Older) release which unfortunately isn't stable (According to Composer stability settings).  And therefore trying to override this by hard coding the older version will be rejected by composer with a message:

The package is not available in a stable-enough version according to your minimum-stability setting see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.

Luckily, there's a way to override Composer's stability requirement and that is achieved like so:

"symfony/console": "2.6.*@dev"

References
http://stackoverflow.com/questions/26202341/the-package-is-not-available-in-a-stable-enough-version